ツールボックスの定義

<< 目次を表示 >>

ページ位置:  Enterprise Architectの拡張(SDK) > MDGテクノロジーを独自に定義 > プロファイルの作成 > プロファイルの作成と編集 > プロファイルエディタの利用 >

ツールボックスの定義

MDGテクノロジーでは、独自のツールボックスを定義することもできます。それぞれのツールボックスプロファイルには、ツールボックスの内容の定義が含まれます。ツールボックスの上部にあるメニューボタンから呼び出した場合や、ツールボックスと関連づけられた種類のダイアグラムを開いた場合に、独自定義のツールボックスが表示されます。

 

 

プロファイルエディタを利用したツールボックスプロファイルの定義

#

操作方法

1

もしMDGテクノロジーを生成するためのパッケージ構成が存在しない場合、モデルテンプレートの機能を利用してパッケージ構成をモデルブラウザに追加します。

モデルブラウザ内で、ステレオタイプ <<toolbox profile>> のパッケージ内のダイアグラムを開きます。

(参照:プロファイルエディタの利用

2

Enterprise Architectのツールボックスの「プロファイル」グループから「ツールボックス定義の追加」の項目をダイアグラム内にドロップします。ツールボックスプロファイルパッケージの選択ダイアログが表示されます。

3

ステップ2で確認した <<toolbox profile>> のステレオタイプが付加されたパッケージを指定します。

選択してOKボタンを押すと、ツールボックスページの作成ダイアログが表示されます。名前と説明を入力してOKボタンを押します。

4

ツールボックス名を入力します。

ここで指定した名前は、ツールボックスの最上部にあるメニューボタンを押したときに表示されるメニューの項目の名前として利用されます。

5

説明の欄には、必要に応じてツールボックスの説明を入力します。

この説明文は、該当のツールボックスを開いた状態で、要素などの上にマウスカーソルを乗せたときに表示される、ツールチップの説明として利用されます。後述の手順で作成するツールボックスページに説明文を追加すると、その説明文が表示されるようになります。

6

OKボタンを押します。

ダイアグラムが作成され、自動的に作成される要素が配置されます。

7

ツールボックスから要素や接続をダイアグラム内に配置した場合に、通常は特定の種類の要素や接続が作成できます。

別の方法として、ドロップした場合にメニューを表示し、作成する種類を作成時に選択できるようにすることもできます。この機能をサブメニューと呼びます。もし、このサブメニューを利用したい場合には、事前にサブメニューの内容を定義する必要があります。

8

次に、Enterprise Architectのツールボックスの「プロファイルエディタ」グループから「ツールボックスの区画の追加」の項目をダイアグラム内にドロップします。ツールボックス区画の追加ダイアログが表示されます。

9

名前の欄には、ツールボックス内のグループを示す名前を指定します。

ここで指定された名前は、グループ名としてツールボックス内に表示されます。

10

説明の欄は、該当のグループの説明文を入力します。入力した内容はツールチップとして利用されます。

11

アイコンの設定欄はこの時点では利用できません。サブメニューを作る場合のみ設定できます。

12

必要に応じて、チェックボックスにチェックを入れます。

 

  • アイコンのみ: チェックを入れると、項目の名前は表示されず、アイコンのみが表示されます。
  • サブメニュー: チェックを入れると、対象のページはサブメニューの定義として利用できます。
  • 共通: チェックを入れると、常に表示されるグループになります。
  • 折りたたんで表示: チェックを入れると、グループの内容が表示されない形式が既定の形式になります。

13

作成したグループに、要素や接続を追加していきます。追加ボタンの右端にある下向きの矢印を押します。メニューが表示されますので、実行する項目を選択して下さい。メニューに表示される項目は以下の通りです。

 

  • ステレオタイプの追加: 独自に定義したステレオタイプ要素を追加します。対象の要素は、同じプロジェクト内で定義されてなければなりません。また、最終的に同じMDGテクノロジーファイルに含まれる必要があります。項目を選択すると、ステレオタイプ要素の選択ダイアログが表示されますので、対象の要素を指定して下さい。
  • 既定の種類の追加:
    • 要素: UMLで定義されている要素を追加します。ツールボックスに表示される名前を別名として入力した後、要素の種類を指定します。要素の種類名は英語で表示されます。
    • 接続: UMLで定義されている接続を追加します。ツールボックスに表示される名前を別名として入力した後、接続の種類を指定します。接続の種類名は英語で表示されます。
  • サブメニューの追加: サブメニューを追加します。追加する前に、サブメニューの定義を完了しておく必要があります。この項目を選択後、サブメニューの定義を示すステレオタイプ要素を選択してください。別名の欄は、ツールボックスに表示される名前を入力します。
  • 新規項目の追加: 別名のみを指定して、新規に項目を指定します。項目の詳細は別途定義する必要があります。定義がない場合、ツールボックスの項目としては意味のない項目になります。

 

追加ボタンをそのまま押した場合には、「ステレオタイプの追加」と同じ動作になります。

14

なお、既存の外部のMDGテクノロジーで定義されている要素を追加することもできます。例えば、SysML1.3で定義されているブロック要素を追加する場合を考えます。

このような要素を追加する場合には、ステップ13の説明にある、新規項目の追加を実行します。別名の欄に、ツールボックス内の項目名として表示される文字列を指定し、OKボタンを押します。

 

ツールボックスアイテムが追加されますので、ステレオタイプの欄に以下のような形式で対象の項目の詳細を指定します。

 

TechnologyID::StereotypeName(BaseUMLType)

 

ここで、TechnologyIDはMDGテクノロジーのIDになります。StereotypeNameは作成する要素のステレオタイプ名あるいはメタクラス名になります。BaseUMLTypeは、該当の項目の、UMLでの種類名になります。先ほどのSysML1.3の例の場合、以下のようになります。

 

SysML1.3::Block(UML::Class)

 

なお、すべての要素が元になるUMLのクラス名を持っているとは限りません。この元の種類名を知るためには、該当の要素や接続をモデル内に作成後、プロパティ画面からステレオタイプを削除して下さい。すると、再度プロパティダイアログを開くと元になっている要素や接続の種類名が表示されます。SysML1.3のブロックの場合、クラス要素として表示されます。

15

ツールボックスから項目をドロップした場合にパターンを配置したい場合には、「追加」ボタンで表示されるメニューで「新規項目の追加」を選択して項目を追加し、「ステレオタイプ」の欄に以下のように入力してください。

 

    TechnologyID::PatternName(UMLPattern)

 

ここで、TechnologyIDは対象のMDGテクノロジーのIDです。 PatternNameは独自に定義したパターンの名前です。例えば、以下のように設定します。

 

BusFramework::Builder(UMLPattern)

 

パターンを追加する場合に、利用者の選択・設定無しに常に追加するようにしたい場合には、 (UMLPattern) を (UMLPatternSilent) に変更してください。

 

プロジェクトに格納されているパターンを呼び出したい場合には、以下のように指定します。

 

  PatternCategory::PatternName(UMLPattern)

 

例えば、以下のようになります。

 

  GoF Behavioral Patterns::Mediator(UMLPattern)

16

ツールボックスの個々の項目について、必要に応じてアイコンを指定することもできます。

 

アイコンのサイズは16x16で、ビットマップ画像にする必要があります。透過させる場合には、背景色は明るい灰色 - RGB(192,192,192) に設定する必要があります。

 

アイコンを設定するには、対象の項目を一覧から選択し、ツールボックスのアイコンのセルをクリックすると表示される「...」ボタンを押します。対象の画像を指定し、OKボタンを押して下さい。

17

必要に応じて、13から15までの手順を繰り返します。追加済みの項目は、一覧で選択した状態で削除ボタンを押すと、削除することができます。

全ての内容を入力したら、OKボタンを押して下さい。ダイアグラム内にステレオタイプよそが追加されます。

18

必要に応じて、8から16までの作業を繰り返します。

19

ダイアグラムの背景で右クリックし、UMLプロファイルとして保存してください。保存したUMLプロファイルのXMLファイルをMDGテクノロジーの作成ウィザードの中で指定します。

 

注意:

  • MDGテクノロジーとしてツールボックスに追加される、独自定義の要素については、ツールボックス内の要素を右クリックすると、「タグ付き値と制約の同期」機能を呼び出すことができます。
  • ツールボックスの定義内の、ツールボックス区画の表示順序は、以下のようにして決まります。
  • ダイアグラムのコンテキストメニューからUMLプロファイルを作成した場合には、ダイアグラム内の前後方向の順序によって決まります。後ろにある区画ほど、ツールボックスでは下の方に表示されます。
  • モデルブラウザ内のパッケージのコンテキストメニューからUMLプロファイルを作成した場合には、モデルブラウザ内の要素の上下の位置で決まります。下にある区画ほど、ツールボックスでも下の方に表示されます。

 

 

参照: